Optimisez les performances des applications WAN et LAN avec TCP Express

Présentation

Pour les entreprises qui fournissent des applications Internet et extranet, les inefficacités du protocole TCP/IP, combinées aux effets de la latence du WAN et de la perte de paquets, nuisent aux performances des applications. Résultat : des temps de réponse plus longs et une efficacité d’utilisation de la bande passante considérablement réduite (la capacité à « remplir le tuyau »).

BIG-IP Local Traffic Manager de F5 fournit une pile TCP/IP de pointe qui améliore considérablement les performances des applications sur les réseaux WAN et LAN dans votre environnement réel, contrairement aux bancs de test qui génèrent des rafales de paquets sans reproduire fidèlement les conditions réelles des clients et d’Internet.

Cette pile TCP/IP hautement optimisée, appelée TCP Express, associe plusieurs techniques TCP/IP de pointe aux améliorations décrites dans les RFC les plus récentes. De nombreuses améliorations et extensions développées par F5 réduisent les effets de la congestion et de la perte de paquets, tout en accélérant la reprise. Des outils de test indépendants et les retours d’expérience des clients montrent que TCP Express permet de multiplier jusqu’à 2 les performances pour les utilisateurs finaux et jusqu’à 4 l’efficacité de la bande passante, sans aucune modification des serveurs, des applications ou des postes clients.

Solution

TCP Express : la pile TCP optimisée de F5

TCP Express de F5 est une pile TCP/IP de pointe, conforme aux normes, qui tire parti des optimisations prises en charge nativement par différents systèmes d’exploitation clients et serveurs, ainsi que d’optimisations indépendantes du système d’exploitation. La pile TCP/IP de F5 intègre des centaines d’améliorations qui optimisent l’efficacité des réseaux WAN et LAN, notamment :

  • Pour les réseaux LAN à haut débit: la pile TCP de F5 augmente rapidement la taille des mémoires tampons et détecte les faibles latences afin de gérer la congestion.
  • Pour les WAN à faible débit: la pile TCP de F5 détecte le débit du client et estime la bande passante afin de limiter la perte de paquets et de faciliter la récupération en cas de paquets perdus.

Au cœur de BIG-IP Local Traffic Manager se trouve l’architecture TMOS, qui fournit la pile TCP/IP optimisée de F5 à toutes les plateformes BIG-IP et à tous les modules logiciels complémentaires. Ces optimisations uniques, qui s’étendent aux clients et aux serveurs dans les communications LAN et WAN, confèrent à la solution F5 une longueur d’avance sur les systèmes qui traitent les paquets individuellement et ne peuvent offrir de fonctionnalités comparables, ni atteindre de tels niveaux d’optimisation, de récupération après perte de paquets ou d’intermédiation entre des clients et des serveurs non optimaux.

L’association de l’architecture de proxy complet TMOS de F5 et de TCP Express améliore considérablement les performances de toutes les applications basées sur TCP. Il a été démontré que, grâce à ces technologies, BIG-IP permet de :

  • Améliorer les débits de transfert pour tous les types de clients connectés
    • Gain de performances moyen de 79 % pour les utilisateurs du haut débit
    • Gain de performances moyen de 35 % pour les clients utilisant une connexion par modem
  • Améliorer la fiabilité de la connexion pour les clients utilisant une connexion par modem
    • Réduction moyenne de 56 % des erreurs TCP/IP (principalement des expirations de délai TCP)
  • Améliorer l’efficacité de la bande passante auprès des fournisseurs d’accès à Internet existants
    • Augmentation de 224 % des données transmises sur le réseau (amélioration de 3,2 fois)
    • Réduction de 50 % du nombre de paquets transmis sur le réseau (amélioration d’un facteur 2)
    • Élimination de 63 % des paquets TCP « vides » (amélioration de 2,7 fois)

Les sections suivantes décrivent l’architecture sous-jacente de TMOS, ainsi qu’une partie des RFC TCP standard et des optimisations utilisées par TCP Express pour optimiser les flux de trafic. Comme il n’existe pas de solution universelle, ce document explique également comment personnaliser les profils TCP et gérer les communications avec les systèmes existants.

Architecture TMOS et intermédiation des piles TCP/IP

La plupart des entreprises ne mettent pas souvent à jour les systèmes d’exploitation de leurs serveurs, et certaines applications continuent de fonctionner sur des systèmes très anciens. Cette infrastructure héritée peut entraîner des retards importants dans la mise à disposition des applications sur le WAN. BIG-IP Local Traffic Manager avec TCP Express peut protéger et optimiser de manière transparente les piles TCP anciennes ou non conformes susceptibles de s’exécuter sur des serveurs au sein d’un centre de données d’entreprise. Pour ce faire, il maintient la compatibilité avec ces équipements tout en exploitant indépendamment les optimisations de la pile TCP/IP de F5 côté client de la connexion, afin d’offrir un comportement TCP entièrement indépendant et optimisé pour chaque équipement connecté et quelles que soient les conditions du réseau.

En tant que proxy complet assurant l’interconnexion de différentes piles TCP/IP, TMOS joue un rôle clé dans de nombreuses optimisations WAN proposées par l’ensemble unique de fonctionnalités TCP Express de F5. Les connexions client et serveur sont isolées, contrôlées et optimisées indépendamment afin d’offrir les meilleures performances à chaque appareil connecté.

BIG-IP Local Traffic Manager évite aux clients et aux serveurs d’avoir à négocier le plus petit dénominateur commun pour leurs communications. Il joue le rôle d’intermédiaire pour le compte du client (fonction appelée « Stack Brokering ») et utilise TCP Express pour optimiser la transmission côté client, tout en maintenant des connexions optimisées pour les serveurs au sein du réseau, comme illustré dans la figure suivante.

Souvent, les entreprises ne disposent pas des ressources nécessaires pour supprimer ou remplacer leurs serveurs et applications existants, ou n’en ont tout simplement pas besoin. Pour prendre en charge ces systèmes, BIG-IP Local Traffic Manager assure une médiation permettant la communication entre des appareils non optimisés, voire incompatibles, notamment :

  • Maintenir des MSS distinctes pour les clients et les serveurs afin de garantir que les deux transmettent les données à un débit optimal. Les clients et les serveurs communiquent leur MSS afin de déterminer la quantité maximale de données pouvant être placée dans un segment TCP. Les deux parties négocient la MSS pour tenter d’établir la communication la plus compatible possible, mais cela empêche souvent l’optimisation du client ou du serveur en les obligeant à adopter la plus petite valeur de MSS commune.
  • Maintien d’optimisations telles que les accusés de réception sélectifs TCP (SACK) ou les horodatages TCP (et bien d’autres) pour les clients lorsqu’ils se connectent à des serveurs qui ne les prennent pas en charge.
  • Optimisation dynamique et automatique de la taille des fenêtres TCP et des informations de congestion TCP pour chaque appareil connecté (chaque client et chaque serveur).
  • Maintenir l’interopérabilité entre des piles telles que Windows et d’anciens systèmes Solaris qui ne prennent pas en charge les paquets TCP FIN-PUSH. Il ne s’agit là que d’un exemple parmi les différents problèmes d’interopérabilité des piles auxquels sont souvent confrontées les entreprises qui cherchent à servir une large population d’utilisateurs.

En plus d’améliorer les communications WAN, BIG-IP Local Traffic Manager étend ces capacités à l’ensemble de l’infrastructure en faisant office de passerelle ou de dispositif de traduction entre tous les clients et les serveurs back-end. Au final, BIG-IP Local Traffic Manager améliore les performances tout en masquant les inefficacités du réseau. Cela réduit les coûts et la complexité en évitant d’avoir à mettre à jour et à optimiser chaque client et chaque serveur.

Améliorations apportées par F5 aux RFC TCP/IP

Parmi les principales améliorations apportées par F5 à TCP/IP figurent :

  • Accélération côté client et prévention des erreurs
  • Amélioration de l’utilisation des liaisons
  • Contrôles TCP personnalisables

Ces améliorations ont été apportées aux RFC standard du secteur. Les sections suivantes présentent certaines des principales RFC de TCP Express.

RFC d’accélération des clients et d’évitement des erreurs

  • Accusés de réception différés, algorithme de Nagle (RFC 896, 1122) Permet à BIG-IP Local Traffic Manager d’accélérer la transmission des données en réduisant le nombre de paquets à transmettre. Les accusés de réception différés fournissent un mécanisme standard permettant de déterminer quand les paquets d’accusé de réception doivent être envoyés afin de réduire les accusés de réception redondants. En outre, l’algorithme de Nagle fournit une procédure standard permettant de regrouper de nombreux petits paquets en un nombre réduit de paquets plus volumineux.
  • Accusés de réception sélectifs (RFC 2018, RFC 2883) Permet à BIG-IP Local Traffic Manager de traiter plus efficacement et plus rapidement les paquets perdus et réordonnés sur les réseaux WAN et les réseaux sujets aux pertes. Cette fonctionnalité est activée par défaut pour les communications Internet sous Windows XP et les versions ultérieures, ainsi que dans toutes les autres piles TCP modernes. Des extensions permettent de spécifier l’utilisation d’une option SACK ou d’accuser réception des paquets en double.
  • Notification explicite de congestion ECN (RFC 3168, 2481) permet à BIG-IP Local Traffic Manager de signaler de manière proactive aux pairs que les routeurs intermédiaires sont surchargés, afin qu’ils puissent réduire leur débit et éviter la perte de paquets. Les indicateurs réservés de l’en-tête TCP (ECE et CWR) peuvent être utilisés pour signaler la congestion au pair.
  • Retransmissions limitées et rapides (RFC 3042, RFC2582) Permet de retransmettre efficacement les données perdues, ce qui peut éliminer les effets des expirations de délai dues à la perte de paquets.
  • Fenêtres initiales de congestion adaptatives (RFC 3390) Réduit l’impact du mécanisme d’évitement de congestion lié au démarrage lent de TCP. Des études portant sur des fenêtres initiales de congestion plus grandes ont montré un gain de 30 % pour les transferts HTTP via des liaisons satellite et une amélioration de 10 % pour les utilisateurs de connexions commutées à 28,8 bit/s, sans augmentation concomitante du taux de perte. Pour des connexions TCP partageant un même chemin (transferts de 16 Ko vers 100 hôtes Internet), l’augmentation de la fenêtre a permis d’améliorer d’environ 25 % les transferts utilisant une fenêtre initiale de quatre segments (MSS de 512 octets), par rapport à une fenêtre initiale d’un seul segment.

RFC sur l’amélioration de l’utilisation des liaisons

  • Démarrage lent de TCP avec évitement de congestion (RFC 3390, 2581) Cette méthode permet de déterminer progressivement la quantité adéquate de données à transmettre sur la liaison sans la saturer, afin d’éviter la perte de paquets. Cette fonctionnalité aide les organisations à mieux utiliser leur bande passante et à obtenir des débits plus élevés sur leurs connexions Internet publiques et leurs lignes louées existantes.
  • Contrôle du délai de bande passante (RFC 793, RFC 2914, RFC 1257) F5 a amélioré et étendu le calcul du délai de bande passante afin d’estimer plus précisément la charge optimale à appliquer au réseau sans dépasser sa capacité.

RFC relatives aux extensions TCP

  • Horodatages (RFC 1323) BIG-IP Local Traffic Manager permet d’utiliser les horodatages de manière sélective afin d’ajouter des données au segment TCP et de faciliter d’autres optimisations. Bien que les horodatages soient très avantageux sur un réseau moderne, certains routeurs anciens et équipements assurant la traduction d’adresses réseau (NAT) les remettent à zéro ou ne les mettent pas à jour, ce qui annule leur intérêt. Ces fonctionnalités, ainsi que d’autres, peuvent donc être ajustées pour chaque profil.
  • Réduire les risques liés à l’interruption prématurée de l’état TCP TIME-WAIT (RFC 1337) Certaines erreurs de communication peuvent être évitées en optimisant le comportement de l’état TIME-WAIT, notamment en n’effectuant aucune action lors de la réception de segments de réinitialisation dans cet état.
  • Protection contre les attaques par numéro de séquence (RFC1948) TCP Express bloque la plupart des attaques visant à deviner les numéros de séquence grâce à une génération sécurisée des ISN.
  • Améliorer la gestion de la congestion TCP (RFC 3168) TCP Express met en œuvre toutes les méthodes les plus récentes d’évitement de la congestion et de reprise après congestion disponibles aujourd’hui sur Internet, afin d’augmenter la bande passante utilisable et d’accélérer la reprise en cas de congestion.
  • Améliorer le démarrage lent de TCP avec de grandes fenêtres de congestion (RFC 3742) Utilise un comportement de démarrage lent plus prudent afin d’éviter des pertes importantes lorsque les connexions utilisent de très grandes fenêtres TCP.
  • Comptage approprié des octets (RFC 3465) Utilise le nombre d’octets précédemment non acquittés par chaque ACK afin d’ajuster plus intelligemment la fenêtre et d’améliorer les performances TCP.
  • Amélioration de l’algorithme de récupération rapide de TCP (NewReno) (RFC 3782) La modification NewReno apportée à l’algorithme de récupération rapide de TCP introduit un léger changement permettant à un émetteur TCP d’utiliser des accusés de réception partiels pour déduire le prochain segment à envoyer lorsque SACK serait utile, mais n’est pas disponible.

Amélioration collective des performances

Étant donné que TCP Express met en œuvre des centaines d’améliorations concrètes de l’interopérabilité TCP et corrige les piles de produits disponibles dans le commerce (Windows 7 et versions ultérieures, IBM AIX, Sun Solaris, entre autres) ou propose des solutions de contournement, aucune technique d’optimisation ne représente à elle seule la majeure partie des gains de performances. Ces optimisations dépendent du type de client/serveur et des caractéristiques du trafic. Par exemple :

  • Avec le haut débit, où la bande passante disponible est bien plus importante, la plupart des connexions TCP exploitent naturellement moins efficacement la capacité totale de la liaison. BIG-IP propose donc des optimisations supplémentaires.
  • Pour un client utilisant une connexion commutée, les principaux avantages de TCP Express sont que BIG-IP peut réduire le nombre total de paquets transmis pour une transaction donnée, tout en accélérant les retransmissions.

BIG-IP continue de réduire les allers-retours des paquets et d’accélérer les retransmissions, comme avec une connexion commutée, mais sur des connexions plus rapides. BIG-IP Local Traffic Manager et TCP Express optimisent également le contrôle de la congestion et la mise à l’échelle de la fenêtre afin d’améliorer la bande passante maximale. Bien que les améliorations puissent être plus perceptibles pour les utilisateurs de connexions commutées, elles sont statistiquement plus évidentes pour les utilisateurs du haut débit, car certaines optimisations améliorent considérablement les performances maximales sur les liaisons plus rapides.

En règle générale, plus le volume de données échangées est important, plus les optimisations de la bande passante s’appliquent. À l’inverse, moins le volume de données échangées est important, plus les optimisations du temps aller-retour (RTT) s’appliquent. Par conséquent, les profils de trafic qui échangent peu de données, comme les connexions par ligne commutée, bénéficient davantage des optimisations que les connexions haut débit. Pour les profils de trafic qui échangent beaucoup de données, ce sont les connexions haut débit qui en bénéficient le plus. Dans les deux cas, TCP Express permet d’obtenir des gains significatifs.

Contrôles TCP personnalisables

Bien que TCP Express soit automatique et ne nécessite aucune modification, BIG-IP Local Traffic Manager permet aux utilisateurs de contrôler précisément la pile TCP afin d’adapter les communications TCP aux besoins spécifiques de l’entreprise. Il est notamment possible de sélectionner des optimisations et des paramètres au niveau du serveur virtuel, pour chaque application prise en charge par l’appareil. Les administrateurs peuvent utiliser un profil TCP pour ajuster chacune des variables TCP suivantes :

  • recyclage des connexions en attente
  • ACK différés
  • MSS du proxy
  • options du proxy
  • acceptation différée
  • accusés de réception sélectifs
  • ECN
  • transmission limitée
  • rfc1323
  • démarrage lent
  • délai lié à la bande passante
  • Nagle
  • tampon du proxy

Les administrateurs peuvent également utiliser ces contrôles pour ajuster les communications TCP en fonction de conditions réseau particulières ou d’exigences applicatives spécifiques. Les clients des secteurs de la téléphonie mobile et des fournisseurs de services constatent que cette flexibilité leur permet d’améliorer davantage les performances, la fiabilité et l’utilisation de la bande passante en adaptant les communications aux appareils connus (tels que les téléphones mobiles) et aux conditions du réseau.

Réglage des paramètres de la pile pour les applications

TCP Express offre des paramètres de pile flexibles permettant d’optimiser les services personnalisés. Par exemple, vous pouvez ajuster ces paramètres afin d’optimiser une application ASP destinée aux utilisateurs mobiles. Le tableau suivant décrit les paramètres de pile modifiables de BIG-IP Local Traffic Manager.

Optimisation du trafic hautement interactif sur le réseau local

Si le trafic sur un réseau local est hautement interactif, F5 recommande d’utiliser un autre ensemble de paramètres TCP afin d’obtenir des performances optimales. F5 a constaté que l’algorithme de Nagle est très efficace pour réduire le nombre de paquets et assurer la compression générale ainsi que la mise en cache dans la RAM sur un réseau étendu. En outre, l’ajustement de la taille de différentes mémoires tampons peut améliorer les communications hautement interactives sur les réseaux locaux à faible latence, le seul inconvénient possible étant une utilisation accrue de la mémoire sur le BIG-IP Local Traffic Manager.

Le tableau suivant décrit les paramètres modifiables du profil TCP.

Autres technologies d’accélération F5

TCP Express est complété par d’autres fonctionnalités et produits d’accélération F5 qui permettent de réduire davantage les temps de téléchargement pour les utilisateurs et d’optimiser les ressources de l’infrastructure.

Parmi les autres fonctionnalités d’accélération intégrées à BIG-IP Local Traffic Manager figurent :

  • La compression HTTP utilise des fonctionnalités de compression GZIP hautement configurables afin de réduire le volume de données transférées sur une ligne.
  • Fast Cache décharge les serveurs et économise leurs ressources processeur en mettant en cache les applications prioritaires et en offrant un contrôle accru pour l’hébergement de plusieurs applications sur un système partagé. Le stockage en cache des données compressées accélère encore davantage la diffusion du contenu et améliore l’évolutivité de BIG-IP.
  • OneConnect augmente la capacité des serveurs jusqu’à 60 % en déchargeant les connexions TCP des serveurs.
  • Content Spooling réduit la surcharge TCP sur les serveurs afin d’augmenter leur capacité jusqu’à 15 % en diminuant le nombre d’opérations de segmentation TCP qu’ils doivent effectuer.

Conclusion

Pour les organisations qui cherchent à améliorer la capacité et les performances de leur infrastructure, BIG-IP Local Traffic Manager offre une solution unique qui optimise de manière transparente l’efficacité de chaque client et serveur connecté. La technologie exclusive TCP Express de F5 apporte des gains inégalés et concrets en matière de performances réseau et applicatives, tout en offrant aux organisations un niveau de contrôle sans précédent pour optimiser les communications TCP des applications stratégiques.

PUBLIÉ LE 27 OCTOBRE 2017