Optimice el rendimiento de las aplicaciones WAN y LAN con TCP Express
Descripción general
En las empresas que ofrecen aplicaciones de Internet y extranet, las ineficiencias de TCP/IP, sumadas a los efectos de la latencia de la WAN y la pérdida de paquetes, perjudican el rendimiento de las aplicaciones. ¿El resultado? Tiempos de respuesta más largos y una eficiencia de uso del ancho de banda considerablemente menor (la capacidad de «llenar el canal»).
BIG-IP Local Traffic Manager de F5 proporciona una pila TCP/IP de última generación que mejora drásticamente el rendimiento de las aplicaciones WAN y LAN en su red real, no en bancos de pruebas que generan grandes volúmenes de paquetes y que no reproducen con precisión las condiciones reales de los clientes y de Internet.
Esta pila TCP/IP altamente optimizada, denominada TCP Express, combina varias técnicas TCP/IP de vanguardia con las mejoras de los RFC más recientes. Las numerosas mejoras y extensiones desarrolladas por F5 minimizan los efectos de la congestión, la pérdida de paquetes y su recuperación. Las herramientas de pruebas independientes y las experiencias de los clientes demuestran que TCP Express ofrece a los usuarios finales un rendimiento hasta 2 veces superior y multiplica por 4 la eficiencia del ancho de banda, sin necesidad de modificar los servidores, las aplicaciones ni los equipos de escritorio de los clientes.
Solución
TCP Express: la pila TCP optimizada de F5
TCP Express de F5 es una pila TCP/IP de última generación basada en estándares que aprovecha tanto las optimizaciones compatibles de forma nativa con diversos sistemas operativos de clientes y servidores como aquellas que no son específicas de ningún sistema operativo. La pila TCP/IP de F5 incorpora cientos de mejoras que aumentan la eficiencia tanto de las redes WAN como de las LAN, entre ellas:
- Para redes LAN de alta velocidad: la pila TCP de F5 amplía rápidamente el tamaño de los búferes y detecta una latencia baja para gestionar la congestión.
- Para redes WAN de baja velocidad: la pila TCP de F5 detecta la velocidad del cliente y calcula el ancho de banda para limitar la pérdida de paquetes y facilitar la recuperación en caso de que se descarten paquetes.
En el núcleo de BIG-IP Local Traffic Manager se encuentra la arquitectura TMOS, que proporciona la pila TCP/IP optimizada de F5 a todas las plataformas BIG-IP y a los módulos complementarios de software. Estas optimizaciones únicas, que se aplican a clientes y servidores tanto en comunicaciones LAN como WAN, sitúan la solución de F5 por delante de los sistemas que procesan los paquetes de forma individual, ya que estos no pueden ofrecer una funcionalidad comparable ni alcanzar estos niveles de optimización, recuperación ante la pérdida de paquetes o intermediación entre clientes y servidores con un rendimiento deficiente.
La combinación de la arquitectura de proxy completo TMOS de F5 y TCP Express mejora drásticamente el rendimiento de todas las aplicaciones basadas en TCP. Se ha demostrado que, gracias a estas tecnologías, BIG-IP puede:
- Mejorar las velocidades de transferencia para todos los tipos de clientes conectados
- Aumento medio del rendimiento del 79 % para los usuarios de banda ancha
- Mejora media del rendimiento del 35 % para los clientes con conexión telefónica
- Mejorar la fiabilidad de la conexión para los clientes de acceso telefónico
- Reducción media del 56 % de los errores de TCP/IP (principalmente tiempos de espera agotados de TCP)
- Aumente la eficiencia del ancho de banda de los proveedores de servicios de Internet actuales
- Aumento del 224 % de los datos transmitidos por la red (mejora de 3,2 veces)
- Reducción del 50 % de los paquetes transmitidos por la red (mejora de 2 veces)
- Se eliminó el 63 % de los paquetes TCP «vacíos» (una mejora de 2,7 veces)
En las siguientes secciones se describen la arquitectura subyacente de TMOS, así como un subconjunto de los RFC estándar de TCP y las optimizaciones que TCP Express utiliza para optimizar los flujos de tráfico. Dado que no existe una solución universal, este documento también explica cómo personalizar los perfiles TCP y gestionar las comunicaciones con sistemas heredados.
Arquitectura de TMOS e intermediación de pilas TCP/IP
La mayoría de las organizaciones no actualizan con frecuencia los sistemas operativos de sus servidores, y algunas aplicaciones siguen ejecutándose en sistemas muy antiguos. Esta infraestructura heredada puede provocar retrasos importantes en la entrega de aplicaciones a través de la WAN. BIG-IP Local Traffic Manager con TCP Express puede proteger y optimizar de forma transparente las pilas TCP antiguas o no conformes que puedan estar ejecutándose en servidores de un centro de datos corporativo. Esto se consigue manteniendo la compatibilidad con dichos dispositivos y, al mismo tiempo, aprovechando de forma independiente las optimizaciones de la pila TCP/IP de F5 en el lado cliente de una conexión, lo que proporciona un comportamiento TCP totalmente independiente y optimizado para cada dispositivo conectado y cada condición de red.
Como proxy completo que interconecta distintas pilas TCP/IP, TMOS es un elemento clave para muchas de las optimizaciones de WAN incluidas en el exclusivo conjunto de funciones TCP Express de F5. Las conexiones de cliente y servidor se aíslan, controlan y optimizan de forma independiente para ofrecer el mejor rendimiento a cada dispositivo conectado.
BIG-IP Local Traffic Manager elimina la necesidad de que los clientes y los servidores negocien el mínimo común denominador para las comunicaciones. Actúa como intermediario en nombre del cliente (lo que se denomina Stack Brokering) y utiliza TCP Express para optimizar la entrega en el lado del cliente, al tiempo que mantiene conexiones optimizadas para el servidor dentro de la red, como se muestra en la siguiente figura.

A menudo, las organizaciones no disponen de los recursos necesarios —o no tienen la necesidad— para retirar o sustituir sus servidores y aplicaciones heredados. Para dar cabida a estos sistemas, BIG-IP Local Traffic Manager actúa como intermediario para facilitar la comunicación entre dispositivos no optimizados o incluso incompatibles, entre ellos:
- Mantener valores de MSS independientes para clientes y servidores a fin de garantizar que ambos transmitan datos a una velocidad óptima. Los clientes y los servidores comunican el MSS para determinar la cantidad máxima de datos que se puede incluir en un segmento de una comunicación TCP. Ambas partes negocian el MSS para intentar establecer la comunicación más compatible posible, pero esto suele impedir que el cliente o el servidor funcionen de forma óptima, ya que se ven obligados a negociar el valor de MSS común más bajo.
- Mantener optimizaciones como los acuses de recibo selectivos de TCP (SACK) o las marcas de tiempo de TCP (entre muchas otras) para los clientes cuando se conectan a servidores no compatibles.
- Optimización dinámica y automática de los tamaños de ventana TCP y de la información de congestión TCP para cada dispositivo conectado (todos los clientes y todos los servidores).
- Mantener la interoperabilidad entre pilas como Windows y sistemas Solaris antiguos que no son compatibles con los paquetes TCP FIN-PUSH. Este es solo un ejemplo de los diversos problemas de interoperabilidad entre pilas a los que suelen enfrentarse las empresas que intentan prestar servicio a una amplia población de usuarios.
Además de mejorar las comunicaciones WAN, BIG-IP Local Traffic Manager extiende estas capacidades a toda la infraestructura al actuar como puente o dispositivo de traducción entre todos los clientes y los servidores back-end. El resultado final es que BIG-IP Local Traffic Manager mejora el rendimiento a la vez que oculta las ineficiencias de la red. Esto reduce los costes y la complejidad al eliminar la necesidad de actualizar y ajustar cada cliente y cada servidor.
Mejoras de F5 en las RFC de TCP/IP
Algunas de las mejoras más importantes de F5 en TCP/IP son:
- Aceleración del cliente y prevención de errores
- Mejoras en la utilización de los enlaces
- Controles TCP personalizables
Estas mejoras se incorporaron a RFC estándar del sector. En las siguientes secciones se destacan algunas de las RFC clave de TCP Express.
RFC de aceleración del cliente y prevención de errores
- Confirmaciones retrasadas, algoritmo de Nagle (RFC 896, 1122) Permite que BIG-IP Local Traffic Manager acelere la entrega de datos reduciendo el número de paquetes que deben transmitirse. Las confirmaciones retrasadas proporcionan un mecanismo estándar para decidir cuándo deben enviarse los paquetes de confirmación, lo que ayuda a reducir los paquetes de confirmación redundantes. Además, el algoritmo de Nagle proporciona un procedimiento estándar para agrupar numerosos paquetes pequeños en un menor número de paquetes más grandes.
- Confirmaciones selectivas (RFC 2018, RFC 2883) Permite que BIG-IP Local Traffic Manager gestione de forma más eficaz y rápida los paquetes perdidos y reordenados en redes WAN y redes con pérdidas. Esta función está habilitada de forma predeterminada para las comunicaciones por Internet en Windows XP y versiones posteriores, así como en todas las demás pilas TCP modernas. Las extensiones permiten especificar el uso de una opción SACK o confirmar la recepción de paquetes duplicados.
- Notificación explícita de congestión ECN (RFC 3168, 2481) permite que BIG-IP Local Traffic Manager indique de forma proactiva a los pares que los enrutadores intermedios están sobrecargados, para que puedan reducir el ritmo y evitar la pérdida de paquetes. Los indicadores reservados de la cabecera TCP (ECE y CWR) se pueden utilizar para comunicar la congestión al par.
- Retransmisiones limitadas y rápidas (RFC 3042, RFC 2582) Permite retransmitir de forma eficiente los datos perdidos, lo que puede eliminar los efectos de los tiempos de espera provocados por la pérdida de paquetes.
- Ventanas iniciales de congestión adaptativas (RFC 3390) Reduce el impacto del mecanismo de prevención de la congestión de inicio lento de TCP. Los estudios sobre ventanas iniciales de congestión más grandes han demostrado una mejora del 30 % en las transferencias HTTP a través de enlaces por satélite y del 10 % para los usuarios de conexiones telefónicas de 28,8 bps, sin que aumente la tasa de pérdida de paquetes. En conexiones TCP que comparten una misma ruta (transferencias de 16 KB a 100 hosts de Internet), el aumento del número de segmentos de la ventana produjo una mejora aproximada del 25 % en las transferencias que utilizaban una ventana inicial de cuatro segmentos (MSS de 512 bytes), en comparación con una ventana inicial de un solo segmento.
RFC sobre mejoras en el aprovechamiento de los enlaces
- Arranque lento de TCP con prevención de la congestión (RFC 3390, 2581) Este método permite determinar progresivamente la cantidad adecuada de datos que se deben transmitir por el enlace sin saturarlo, evitando así la pérdida de paquetes. Esta capacidad ayuda a las organizaciones a aprovechar mejor el ancho de banda y obtener mayores velocidades de transferencia con sus conexiones públicas a Internet y líneas arrendadas actuales.
- Control del retardo del ancho de banda (RFC 793, RFC 2914, RFC 1257) F5 ha mejorado y ampliado el cálculo del retardo del ancho de banda para estimar con mayor precisión la carga óptima que se puede aplicar a la red sin sobrepasar su capacidad.
RFC de extensiones de TCP
- Marcas de tiempo (RFC 1323) BIG-IP Local Traffic Manager permite utilizar de forma selectiva marcas de tiempo que añaden datos al segmento TCP para facilitar otras optimizaciones. Aunque las marcas de tiempo ofrecen grandes ventajas en las redes modernas, algunos routers y dispositivos NAT antiguos las ponen a cero o no las actualizan, lo que anula dichas ventajas. Por ello, esta y otras funciones pueden ajustarse para cada perfil.
- Mejorar los riesgos de eliminación prematura del estado TCP TIME-WAIT (RFC 1337) Existen varios posibles errores de comunicación que pueden evitarse optimizando el comportamiento de TIME-WAIT, especialmente si no se realiza ninguna acción al recibir segmentos de restablecimiento mientras la conexión se encuentra en el estado TIME-WAIT.
- Defensa contra ataques al número de secuencia (RFC1948) TCP Express bloquea la mayoría de los ataques de adivinación de números de secuencia mediante la generación segura de números de secuencia iniciales (ISN).
- Mejorar la gestión de la congestión de TCP (RFC 3168) TCP Express implementa todos los métodos más recientes de prevención y recuperación de la congestión de TCP disponibles actualmente en Internet para aumentar el ancho de banda utilizable y acelerar la recuperación en caso de congestión.
- Mejorar el inicio lento de TCP con ventanas de congestión grandes (RFC 3742) Utiliza un comportamiento de inicio lento más conservador para evitar grandes pérdidas cuando las conexiones utilizan ventanas TCP muy grandes.
- Conteo de bytes apropiado (RFC 3465) Utiliza el número de bytes previamente no confirmados por cada ACK para ajustar el escalado de la ventana de forma más inteligente y mejorar el rendimiento de TCP.
- Mejora del algoritmo de recuperación rápida de TCP (NewReno) (RFC 3782) La modificación NewReno del algoritmo de recuperación rápida de TCP introduce un pequeño cambio mediante el cual un emisor TCP puede utilizar confirmaciones parciales para deducir cuál es el siguiente segmento que debe enviar en situaciones en las que SACK resultaría útil, pero no está disponible.
Mejora colectiva del rendimiento
Dado que TCP Express implementa literalmente cientos de mejoras de interoperabilidad TCP aplicables a entornos reales, y corrige o proporciona soluciones alternativas para pilas de productos disponibles comercialmente (Windows 7 y versiones posteriores, IBM AIX, Sun Solaris y otros), ninguna técnica de optimización por sí sola es responsable de la mayor parte de las mejoras de rendimiento. Estas optimizaciones dependen del tipo específico de cliente/servidor y de las características del tráfico. Por ejemplo:
- En las conexiones de banda ancha, donde hay mucho más ancho de banda, la mayoría de las implementaciones de TCP son, por naturaleza, menos eficientes a la hora de aprovechar toda la capacidad del enlace, por lo que BIG-IP ofrece optimizaciones adicionales.
- Con un cliente conectado mediante acceso telefónico, las principales ventajas de TCP Express son que BIG-IP puede reducir el número total de paquetes transmitidos para una transacción determinada, además de agilizar las retransmisiones.
BIG-IP sigue reduciendo los viajes de ida y vuelta de los paquetes y acelerando las retransmisiones, como ocurre con las conexiones de acceso telefónico, pero en conexiones más rápidas. BIG-IP Local Traffic Manager y TCP Express también optimizan el control de congestión y el escalado de ventanas para mejorar el ancho de banda máximo. Aunque las mejoras para los usuarios de acceso telefónico pueden ser las más perceptibles, las mejoras para los usuarios de banda ancha son las más evidentes desde el punto de vista estadístico, debido al notable efecto que tienen algunas optimizaciones en el rendimiento máximo de los enlaces más rápidos.
Por regla general, cuanto mayor sea la cantidad de datos intercambiados, más optimizaciones del ancho de banda se aplicarán. Cuanto menor sea la cantidad de datos intercambiados, más optimizaciones del tiempo de ida y vuelta (RTT) se aplicarán. Por tanto, los perfiles de tráfico que no intercambian muchos datos, como las conexiones de acceso telefónico, se beneficiarían de una mayor optimización que los de banda ancha. En el caso de los perfiles de tráfico que sí intercambian muchos datos, la banda ancha sería la más beneficiada por la optimización. En ambos casos, se pueden obtener mejoras significativas mediante TCP Express.
Controles TCP personalizables
Aunque TCP Express es automático y no requiere modificaciones, BIG-IP Local Traffic Manager ofrece a los usuarios un control avanzado de la pila TCP para ajustar las comunicaciones TCP según las necesidades específicas de la empresa. Esto incluye la posibilidad de seleccionar optimizaciones y configuraciones en el ámbito del servidor virtual para cada aplicación gestionada por el dispositivo. Los administradores pueden utilizar un perfil TCP para ajustar cada una de las siguientes variables TCP:
- reciclaje de TIME-WAIT
- ACK retrasados
- MSS del proxy
- opciones de proxy
- aceptación diferida
- confirmaciones selectivas
- ECN
- transmisión limitada
- rfc1323
- inicio lento
- retardo del ancho de banda
- Nagle
- búfer del proxy
Los administradores también pueden utilizar estos controles para ajustar la comunicación TCP a condiciones de red específicas o a los requisitos de las aplicaciones. Los clientes de los sectores de la telefonía móvil y los proveedores de servicios consideran que esta flexibilidad les permite mejorar aún más el rendimiento, la fiabilidad y el aprovechamiento del ancho de banda al adaptar la comunicación a dispositivos conocidos (como teléfonos móviles) y a determinadas condiciones de red.
Ajuste de la configuración de la pila para aplicaciones
TCP Express ofrece una configuración flexible de la pila para optimizar servicios personalizados; por ejemplo, puede ajustar esta configuración para optimizar una aplicación ASP destinada a usuarios de dispositivos móviles. En la siguiente tabla se describen los ajustes modificables de la pila de BIG-IP Local Traffic Manager.

Optimización del tráfico altamente interactivo en la LAN
Si el tráfico de una LAN es altamente interactivo, F5 recomienda utilizar un conjunto diferente de ajustes de TCP para obtener el máximo rendimiento. F5 ha comprobado que el algoritmo de Nagle funciona muy bien para reducir el número de paquetes y para la compresión general y el almacenamiento en caché en RAM a través de una WAN. Además, ajustar los distintos tamaños de búfer puede mejorar las comunicaciones altamente interactivas en redes LAN de baja latencia, con el único posible inconveniente de un mayor uso de memoria en BIG-IP Local Traffic Manager.
La siguiente tabla describe los ajustes modificables del perfil TCP.

Otras tecnologías de aceleración de F5
TCP Express se complementa con otras funciones y productos de aceleración de F5 que permiten reducir aún más los tiempos de descarga de los usuarios y optimizar los recursos de infraestructura.
Entre las demás funciones de aceleración integradas en BIG-IP Local Traffic Manager se incluyen:
- La compresión HTTP utiliza funciones de compresión GZIP altamente configurables para reducir la cantidad de bytes transferidos a través de una línea.
- Fast Cache descarga los servidores y ahorra recursos de CPU al almacenar en caché las aplicaciones prioritarias y ampliar el control para alojar varias aplicaciones en un sistema compartido. El almacenamiento en caché de datos comprimidos agiliza aún más la entrega de contenido y mejora la escalabilidad de BIG-IP.
- OneConnect aumenta la capacidad de los servidores hasta un 60 % al descargar de ellos las conexiones TCP.
- Content Spooling reduce la sobrecarga de TCP en los servidores para aumentar su capacidad hasta un 15 % al disminuir la cantidad de segmentación TCP que debe realizarse en ellos.
Conclusión
Para las organizaciones que buscan mejorar la capacidad y el rendimiento de su infraestructura, BIG-IP Local Traffic Manager ofrece una solución única que, de forma transparente, permite que cada cliente y servidor conectado funcione con mayor eficiencia. La exclusiva tecnología TCP Express de F5 proporciona mejoras inigualables y tangibles en el rendimiento de la red y las aplicaciones, y ofrece a las organizaciones un nivel de control sin precedentes para optimizar las comunicaciones TCP de las aplicaciones esenciales.
PUBLICADO EL 27 DE OCTUBRE DE 2017
