Otimize o desempenho de aplicações em WAN e LAN com o TCP Express
Visão geral
Para empresas que fornecem aplicações de Internet e extranet, as ineficiências do TCP/IP, somadas aos efeitos da latência da WAN e da perda de pacotes, prejudicam o desempenho das aplicações. O resultado? Tempos de resposta mais longos e uma redução significativa na eficiência da utilização da largura de banda (a capacidade de "preencher o canal").
O BIG-IP Local Traffic Manager da F5 oferece uma pilha TCP/IP de última geração que proporciona melhorias expressivas no desempenho de aplicações em WAN e LAN para sua rede no mundo real — e não para ambientes de teste que disparam pacotes em massa e não reproduzem com precisão as condições reais dos clientes e da Internet.
Essa pilha TCP/IP altamente otimizada, chamada TCP Express, combina diversas técnicas de TCP/IP de ponta e melhorias presentes nas RFCs mais recentes. Diversas melhorias e extensões desenvolvidas pela F5 minimizam os efeitos do congestionamento, da perda de pacotes e da recuperação. Ferramentas de teste independentes e experiências de clientes mostram que o TCP Express proporciona um ganho de desempenho de até 2 vezes para os usuários finais e uma melhoria de 4 vezes na eficiência da largura de banda, sem nenhuma alteração nos servidores, aplicativos ou desktops dos clientes.
Solução
TCP Express: a pilha TCP otimizada da F5
O TCP Express da F5 é uma pilha TCP/IP de última geração, baseada em padrões, que aproveita otimizações com suporte nativo em diversos sistemas operacionais de clientes e servidores, além de otimizações que não são específicas de nenhum sistema operacional. A pilha TCP/IP da F5 contém centenas de melhorias que aumentam a eficiência tanto de redes WAN quanto de redes LAN, incluindo:
- Para LANs de alta velocidade: a pilha TCP da F5 aumenta rapidamente o tamanho dos buffers e detecta baixa latência para gerenciar o congestionamento.
- Para WANs de baixa velocidade: a pilha TCP da F5 detecta a velocidade do cliente e estima a largura de banda para limitar a perda de pacotes e o tempo de recuperação em caso de descarte de pacotes.
No núcleo do BIG-IP Local Traffic Manager está a arquitetura TMOS, que disponibiliza a pilha TCP/IP otimizada da F5 para todas as plataformas BIG-IP e módulos complementares de software. Essas otimizações exclusivas, que abrangem clientes e servidores em comunicações LAN e WAN, colocam a solução da F5 à frente dos sistemas que processam os pacotes individualmente e não conseguem oferecer funcionalidades comparáveis — nem alcançar esses níveis de otimização, recuperação de perda de pacotes ou intermediação entre clientes e servidores com desempenho abaixo do ideal.
A combinação da arquitetura de proxy completo TMOS da F5 com o TCP Express melhora significativamente o desempenho de todos os aplicativos baseados em TCP. Com o uso dessas tecnologias, foi comprovado que o BIG-IP é capaz de:
- Melhorar as taxas de transferência para todos os tipos de clientes conectados
- Aumento médio de 79% no desempenho para usuários de banda larga
- Aumento médio de 35% no desempenho para clientes com conexão discada
- Melhore a confiabilidade da conexão para clientes de acesso discado
- Redução média de 56% nos erros de TCP/IP (principalmente tempos limite de TCP)
- Aumente a eficiência da largura de banda entre os provedores de internet existentes
- Aumento de 224% nos dados transmitidos pela rede (melhoria de 3,2 vezes)
- Redução de 50% nos pacotes transmitidos pela rede (melhoria de 2x)
- Eliminação de 63% dos pacotes TCP "vazios" (melhoria de 2,7 vezes)
As seções a seguir descrevem a arquitetura de suporte do TMOS, bem como um subconjunto das RFCs padrão de TCP e das otimizações que o TCP Express utiliza para otimizar os fluxos de tráfego. Como não existe uma solução única que atenda a todos os casos, este documento também descreve como personalizar os Perfis TCP e gerenciar a comunicação com sistemas legados.
Arquitetura TMOS e intermediação da pilha TCP/IP
A maioria das organizações não atualiza os sistemas operacionais dos servidores com frequência, e alguns aplicativos continuam sendo executados em sistemas muito antigos. Essa infraestrutura legada pode causar atrasos significativos na entrega de aplicativos pela WAN. O BIG-IP Local Traffic Manager com TCP Express pode proteger e otimizar de forma transparente pilhas TCP antigas ou não compatíveis que estejam em execução em servidores de um data center corporativo. Isso é possível mantendo a compatibilidade com esses dispositivos e, ao mesmo tempo, aproveitando de forma independente as otimizações da pilha TCP/IP da F5 no lado do cliente de uma conexão, proporcionando um comportamento TCP totalmente independente e otimizado para cada dispositivo conectado e cada condição de rede.
Como um proxy completo que interliga diversas pilhas TCP/IP, o TMOS é um componente essencial para muitas das otimizações de WAN incluídas no conjunto exclusivo de recursos TCP Express da F5. As conexões de clientes e servidores são isoladas, controladas e otimizadas de forma independente para oferecer o melhor desempenho a cada dispositivo conectado.
O BIG-IP Local Traffic Manager elimina a necessidade de clientes e servidores negociarem o menor denominador comum para as comunicações. Ele atua como intermediário em nome do cliente (processo chamado de Stack Brokering) e usa o TCP Express para otimizar a entrega no lado do cliente, mantendo conexões otimizadas para o servidor no interior da rede, conforme mostrado na figura a seguir.

Muitas vezes, as organizações não têm os recursos — ou a necessidade — para remover ou substituir seus servidores e aplicativos legados. Para dar suporte a esses sistemas, o BIG-IP Local Traffic Manager atua como intermediário, permitindo a comunicação entre dispositivos não otimizados ou até mesmo incompatíveis, incluindo:
- Manter MSSs separados para clientes e servidores a fim de garantir que ambos transmitam dados a uma taxa ideal. Clientes e servidores informam o MSS para determinar a quantidade máxima de dados que pode ser inserida em um segmento de comunicação TCP. As duas partes negociam o MSS na tentativa de estabelecer a comunicação mais compatível possível, mas isso muitas vezes faz com que o cliente ou o servidor não opere de forma otimizada, pois ambos são obrigados a negociar o menor valor de MSS em comum.
- Manter otimizações como Confirmações Seletivas de TCP (SACK) ou Marcas de Tempo de TCP (entre muitas outras) para os clientes quando eles se conectam a servidores sem suporte.
- Otimização dinâmica e automática dos tamanhos das janelas TCP e das informações de congestionamento TCP para cada dispositivo conectado (todos os clientes e todos os servidores).
- Manter a interoperabilidade entre pilhas, como as do Windows e de sistemas Solaris mais antigos, que não são compatíveis com TCP FIN-PUSHs. Este é apenas um exemplo dos diversos problemas de interoperabilidade entre pilhas que frequentemente desafiam empresas que buscam atender a uma ampla base de usuários.
Além de melhorar as comunicações WAN, o BIG-IP Local Traffic Manager estende esses recursos a toda a infraestrutura, atuando como uma ponte ou um dispositivo de tradução entre todos os clientes e servidores de back-end. Como resultado, o BIG-IP Local Traffic Manager melhora o desempenho e, ao mesmo tempo, oculta as ineficiências da rede. Isso reduz os custos e a complexidade, eliminando a necessidade de atualizar e ajustar cada cliente e cada servidor.
Aprimoramentos da F5 nas RFCs de TCP/IP
Algumas das melhorias mais importantes da F5 em TCP/IP incluem:
- Aceleração do cliente e prevenção de erros
- Melhorias na utilização do link
- Controles de TCP personalizáveis
Essas melhorias foram feitas em RFCs que são padrão do setor. As seções a seguir destacam algumas das principais RFCs do TCP Express.
RFCs de aceleração do cliente e prevenção de erros
- Confirmações atrasadas, algoritmo de Nagle (RFC 896, 1122) Permite que o BIG-IP Local Traffic Manager acelere a entrega de dados reduzindo o número de pacotes que precisam ser transmitidos. As confirmações atrasadas fornecem um mecanismo padrão para determinar quando os pacotes de confirmação precisam ser enviados, ajudando a reduzir pacotes de confirmação redundantes. Além disso, o algoritmo de Nagle fornece um procedimento padrão para agrupar vários pacotes menores em uma quantidade menor de pacotes maiores.
- Confirmações seletivas (RFC 2018, RFC 2883) Permite que o BIG-IP Local Traffic Manager lide de forma mais eficaz e rápida com pacotes perdidos e reordenados em WANs e redes com perdas. Esse recurso é habilitado por padrão no Windows XP e versões posteriores para comunicações pela Internet, bem como em todas as outras pilhas TCP modernas. As extensões permitem especificar o uso de uma opção SACK ou confirmar o recebimento de pacotes duplicados.
- Notificação Explícita de Congestionamento ECN (RFC 3168, 2481) Permite que o BIG-IP Local Traffic Manager sinalize proativamente aos pares que os roteadores intermediários estão sobrecarregados, para que possam reduzir a taxa de transmissão e evitar a perda de pacotes. Os sinalizadores reservados no cabeçalho TCP (ECE e CWR) podem ser usados para comunicar o congestionamento ao par.
- Retransmissões limitadas e rápidas (RFC 3042, RFC 2582) Permite a retransmissão eficiente de dados perdidos, o que pode eliminar os efeitos de tempos limite decorrentes da perda de pacotes.
- Janelas iniciais de congestionamento adaptativas (RFC 3390) Reduz o impacto do mecanismo de prevenção de congestionamento de inicialização lenta do TCP. Estudos com janelas iniciais de congestionamento maiores demonstraram um ganho de 30% nas transferências HTTP por links de satélite e uma melhoria de 10% para usuários de conexão discada de 28,8 bps, sem aumento correspondente na taxa de descarte. Em conexões TCP que compartilham um caminho (transferências de 16 KB para 100 hosts da Internet), o aumento do número de segmentos da janela resultou em uma melhoria de aproximadamente 25% nas transferências que usavam uma janela inicial de quatro segmentos (MSS de 512 bytes), em comparação com uma janela inicial de um segmento.
RFCs de melhorias na utilização do link
- Inicialização Lenta do TCP com Prevenção de Congestionamento (RFC 3390, 2581) Este é um método para determinar a quantidade adequada de dados a ser transmitida pelo link sem congestioná-lo, evitando assim a perda de pacotes. Esse recurso ajuda as organizações a aumentar a utilização da largura de banda, alcançando taxas de transferência mais altas em suas conexões existentes com a Internet pública e em linhas dedicadas.
- Controle de atraso de largura de banda (RFC 793, RFC 2914, RFC 1257) A F5 aprimorou e expandiu o cálculo de atraso de largura de banda para estimar com mais precisão a carga ideal a ser aplicada à rede sem exceder sua capacidade.
RFCs de extensão do TCP
- Marcas de tempo (RFC 1323) O BIG-IP Local Traffic Manager permite o uso seletivo de marcas de tempo, que adicionam dados ao segmento TCP para auxiliar em outras otimizações. Embora as marcas de tempo sejam muito vantajosas em redes modernas, alguns roteadores legados e dispositivos que realizam NAT zeram ou não atualizam essas marcas, anulando o benefício. Por isso, esse e outros recursos podem ser ajustados individualmente em cada perfil.
- Reduzir os riscos de encerramento indevido do estado TCP TIME-WAIT (RFC 1337) Há alguns possíveis erros de comunicação que podem ser evitados otimizando o comportamento do estado TIME-WAIT, especialmente ao não executar nenhuma ação ao receber segmentos de redefinição enquanto a conexão estiver nesse estado.
- Defesa contra ataques de números de sequência (RFC1948) O TCP Express bloqueia a maioria dos ataques de adivinhação de números de sequência usando a geração segura de ISN.
- Aprimorar o gerenciamento de congestionamento do TCP (RFC 3168) O TCP Express implementa todos os métodos mais recentes de prevenção e recuperação de congestionamento do TCP disponíveis atualmente na Internet, a fim de aumentar a largura de banda utilizável e acelerar a recuperação em caso de congestionamento.
- Aprimorar a inicialização lenta do TCP para conexões TCP com janelas de congestionamento grandes (RFC 3742) Usa um comportamento de inicialização lenta mais conservador para evitar grandes volumes de perda quando as conexões utilizam janelas TCP muito grandes.
- Contagem Apropriada de Bytes (RFC 3465) Usa o número de bytes anteriormente não confirmados por cada ACK para proporcionar um dimensionamento de janela mais inteligente e aumentar o desempenho do TCP.
- Aprimoramento do algoritmo de recuperação rápida do TCP (NewReno) (RFC 3782) A modificação NewReno no algoritmo de recuperação rápida do TCP introduz uma pequena alteração que permite a um remetente TCP usar confirmações parciais para fazer inferências e determinar o próximo segmento a ser enviado em situações nas quais o SACK seria útil, mas não está disponível.
Melhoria Coletiva de Desempenho
Como o TCP Express implementa literalmente centenas de melhorias de interoperabilidade TCP comprovadas em situações reais e corrige ou oferece soluções alternativas para pilhas de produtos disponíveis comercialmente (Windows 7 e versões posteriores, IBM AIX, Sun Solaris, entre outros), nenhuma técnica de otimização isolada é responsável pela maior parte dos ganhos de desempenho. Essas otimizações dependem do tipo específico de cliente/servidor e das características do tráfego. Por exemplo:
- Em conexões de banda larga, nas quais há muito mais largura de banda disponível, a maioria das implementações de TCP é naturalmente menos eficiente no aproveitamento de toda a capacidade do link. Por isso, o BIG-IP oferece otimizações adicionais.
- Para um cliente com conexão discada, as principais vantagens do TCP Express são que o BIG-IP pode reduzir o número total de pacotes transmitidos em uma determinada transação, além de proporcionar retransmissões mais rápidas.
O BIG-IP continua reduzindo as idas e vindas dos pacotes e acelerando as retransmissões, assim como nas conexões discadas, mas em conexões mais rápidas. O BIG-IP Local Traffic Manager e o TCP Express também otimizam o controle de congestionamento e o dimensionamento da janela para melhorar a largura de banda máxima. Embora as melhorias para usuários de conexão discada possam ser as mais perceptíveis, as melhorias para usuários de banda larga são as mais evidentes estatisticamente, devido ao impacto significativo de alguns aprimoramentos no desempenho máximo em links mais rápidos.
Como regra geral, quanto mais dados forem trocados, mais otimizações de largura de banda serão aplicadas. Quanto menos dados forem trocados, mais otimizações de tempo de ida e volta (RTT) serão aplicadas. Portanto, perfis de tráfego que não trocam muitos dados, como conexões discadas, teriam mais otimização do que conexões de banda larga. Para perfis de tráfego que trocam muitos dados, as conexões de banda larga teriam o maior nível de otimização. Em ambos os casos, é possível obter ganhos significativos usando o TCP Express.
Controles TCP personalizáveis
Embora o TCP Express seja automático e não exija modificações, o BIG-IP Local Traffic Manager oferece aos usuários controle avançado da pilha TCP para ajustar as comunicações TCP de acordo com necessidades comerciais específicas. Isso inclui a capacidade de selecionar otimizações e configurações no nível do servidor virtual para cada aplicação disponibilizada pelo dispositivo. Os administradores podem usar um perfil TCP para ajustar cada uma das seguintes variáveis TCP:
- reciclagem de TIME-WAIT
- ACKs atrasados
- MSS do proxy
- opções de proxy
- aceitação adiada
- confirmações seletivas
- ECN
- transmissão limitada
- rfc1323
- inicialização lenta
- atraso de largura de banda
- nagle
- buffer de proxy
Os administradores também podem usar esses controles para ajustar a comunicação TCP a condições de rede específicas ou a requisitos de aplicações. Os clientes dos setores de telefonia móvel e de provedores de serviços consideram que essa flexibilidade lhes permite aprimorar ainda mais o desempenho, a confiabilidade e a utilização da largura de banda, adaptando a comunicação a dispositivos conhecidos (como aparelhos celulares) e às condições da rede.
Ajuste das configurações da pilha para aplicações
O TCP Express oferece configurações flexíveis de pilha para otimizar serviços personalizados. Por exemplo, você pode ajustar essas configurações para otimizar um aplicativo ASP disponibilizado a usuários de dispositivos móveis. A tabela a seguir descreve as configurações de pilha modificáveis do BIG-IP Local Traffic Manager.

Otimizando o tráfego altamente interativo na LAN
Se o tráfego em uma LAN for altamente interativo, a F5 recomenda um conjunto diferente de configurações de TCP para obter o máximo desempenho. A F5 constatou que o algoritmo de Nagle funciona muito bem para reduzir a quantidade de pacotes e para compressão geral/armazenamento em cache na RAM em uma WAN. Além disso, ajustes em diversos tamanhos de buffer podem ter um impacto positivo nas comunicações altamente interativas em LANs de baixa latência, tendo como único custo possível o aumento da utilização de memória no BIG-IP Local Traffic Manager.
A tabela a seguir descreve as configurações modificáveis do perfil TCP.

Outras tecnologias de aceleração da F5
O TCP Express é complementado por outros recursos e produtos de aceleração da F5, que ajudam a reduzir ainda mais o tempo de download para os usuários e a otimizar os recursos de infraestrutura.
Outros recursos de aceleração integrados ao BIG-IP Local Traffic Manager incluem:
- A Compressão HTTP usa recursos de compactação GZIP altamente configuráveis para reduzir a quantidade de bytes transferidos por uma linha.
- O Fast Cache reduz a carga dos servidores e economiza recursos de CPU ao armazenar em cache os aplicativos prioritários e ampliar o controle para hospedar vários aplicativos em um sistema compartilhado. O armazenamento de dados compactados em cache agiliza ainda mais a entrega de conteúdo e melhora a escalabilidade do BIG-IP.
- O OneConnect aumenta a capacidade dos servidores em até 60% ao transferir as conexões TCP dos servidores.
- O Content Spooling reduz a sobrecarga de TCP nos servidores, aumentando a capacidade deles em até 15% ao diminuir a quantidade de segmentação TCP que precisa ser realizada nos servidores.
Conclusão
Para organizações que buscam melhorar a capacidade e o desempenho de sua infraestrutura, o BIG-IP Local Traffic Manager oferece uma solução exclusiva que, de forma transparente, torna mais eficiente o funcionamento de cada cliente e servidor conectado. O exclusivo TCP Express da F5 proporciona melhorias incomparáveis no desempenho de redes e aplicações em ambientes reais, além de oferecer às organizações um nível de controle sem precedentes para otimizar as comunicações TCP de aplicações essenciais aos negócios.
PUBLICADO EM 27 DE OUTUBRO DE 2017
