Optimieren Sie die Anwendungsleistung in WAN und LAN mit TCP Express
Überblick
Bei Unternehmen, die Internet- und Extranet-Anwendungen bereitstellen, beeinträchtigen die Ineffizienz von TCP/IP sowie die Auswirkungen von WAN-Latenz und Paketverlusten gemeinsam die Anwendungsleistung. Das Ergebnis: längere Reaktionszeiten der Anwendungen und eine deutlich geringere Effizienz bei der Bandbreitennutzung (also bei der Fähigkeit, die verfügbare Bandbreite voll auszuschöpfen).
Der BIG-IP Local Traffic Manager von F5 bietet einen hochmodernen TCP/IP-Stack, der die Anwendungsleistung in WAN- und LAN-Umgebungen Ihres realen Netzwerks erheblich verbessert – im Gegensatz zu Testsystemen, die lediglich große Mengen an Paketen senden und die tatsächlichen Client- und Internetbedingungen nicht präzise abbilden.
Dieser hochoptimierte TCP/IP-Stack namens TCP Express kombiniert mehrere hochmoderne TCP/IP-Techniken mit Verbesserungen aus den neuesten RFCs. Zahlreiche von F5 entwickelte Optimierungen und Erweiterungen minimieren die Auswirkungen von Überlastungen und Paketverlusten und verbessern die Wiederherstellung. Unabhängige Testtools und Kundenerfahrungen zeigen, dass TCP Express für Endbenutzer eine bis zu doppelt so hohe Leistung und eine viermal höhere Bandbreiteneffizienz ermöglicht – ohne Änderungen an Servern, Anwendungen oder Client-Desktops.
Lösung
TCP Express: Der optimierte TCP-Stack von F5
F5 TCP Express ist ein standardbasierter, hochmoderner TCP/IP-Stack, der sowohl auf Optimierungen zurückgreift, die von verschiedenen Client- und Serverbetriebssystemen nativ unterstützt werden, als auch auf betriebssystemunabhängige Optimierungen. Der TCP/IP-Stack von F5 umfasst Hunderte von Verbesserungen, die die Effizienz sowohl in WANs als auch in LANs steigern, darunter:
- Für Hochgeschwindigkeits-LANs: Der TCP-Stack von F5 vergrößert die Puffer schnell und erkennt niedrige Latenzzeiten, um Überlastungen zu bewältigen.
- Für langsame WANs: Der TCP-Stack von F5 erkennt die Geschwindigkeit des Clients und schätzt die Bandbreite, um Paketverluste zu begrenzen und die Wiederherstellung bei verworfenen Paketen zu optimieren.
Das Herzstück des BIG-IP Local Traffic Manager bildet die TMOS-Architektur, die allen BIG-IP-Plattformen und Software-Zusatzmodulen den optimierten TCP/IP-Stack von F5 zur Verfügung stellt. Diese einzigartigen Optimierungen, die sowohl Clients als auch Server in der LAN- und WAN-Kommunikation umfassen, verschaffen der Lösung von F5 einen Vorsprung gegenüber Systemen, die Pakete einzeln verarbeiten und keine vergleichbare Funktionalität bieten können. Ebenso wenig erreichen sie dieses Maß an Optimierung, Wiederherstellung bei Paketverlusten oder Vermittlung zwischen nicht optimal aufeinander abgestimmten Clients und Servern.
Die Kombination aus der TMOS-Full-Proxy-Architektur von F5 und TCP Express verbessert die Leistung aller TCP-basierten Anwendungen erheblich. Der Einsatz dieser Technologien hat bei BIG-IP nachweislich zu folgenden Ergebnissen geführt:
- Übertragungsraten für alle verbundenen Clienttypen verbessern
- Durchschnittlich 79 % mehr Leistung für Breitbandnutzer
- Durchschnittlich 35 % mehr Leistung für Einwahlkunden
- Verbindungszuverlässigkeit für Einwahl-Clients verbessern
- Durchschnittlich 56 % weniger TCP/IP-Fehler (hauptsächlich TCP-Zeitüberschreitungen)
- Steigern Sie die Bandbreiteneffizienz bei bestehenden Internetanbietern
- 224 % mehr übertragene Daten (3,2-fache Verbesserung)
- 50 % weniger Pakete bei der Übertragung (2-fache Verbesserung)
- 63 % der „leeren“ TCP-Pakete eliminiert (2,7-fache Verbesserung)
In den folgenden Abschnitten werden die zugrunde liegende TMOS-Architektur sowie eine Auswahl der standardmäßigen TCP-RFCs und Optimierungen beschrieben, die TCP Express zur Optimierung des Datenverkehrs verwendet. Da es keine Universallösung gibt, wird in diesem Dokument außerdem erläutert, wie TCP-Profile angepasst und die Kommunikation mit Altsystemen gehandhabt werden kann.
TMOS-Architektur und Vermittlung zwischen TCP/IP-Stacks
Die meisten Unternehmen aktualisieren die Betriebssysteme ihrer Server nur selten, und einige Anwendungen werden weiterhin auf sehr alten Systemen ausgeführt. Diese veraltete Infrastruktur kann bei der Bereitstellung von Anwendungen über das WAN erhebliche Verzögerungen verursachen. BIG-IP Local Traffic Manager mit TCP Express kann ältere oder nicht standardkonforme TCP-Stacks, die möglicherweise auf Servern in einem Unternehmensrechenzentrum ausgeführt werden, abschirmen und transparent optimieren. Dies wird erreicht, indem die Kompatibilität mit diesen Geräten aufrechterhalten wird, während auf der Clientseite einer Verbindung unabhängig davon die TCP/IP-Stack-Optimierungen von F5 genutzt werden. So wird für jedes verbundene Gerät und jede Netzwerkbedingung ein vollständig unabhängiges und optimiertes TCP-Verhalten bereitgestellt.
Als Full Proxy, der verschiedene TCP/IP-Stacks miteinander verbindet, ist TMOS eine Schlüsseltechnologie für viele der WAN-Optimierungen, die im einzigartigen TCP-Express-Funktionsumfang von F5 enthalten sind. Client- und Serververbindungen werden isoliert, gesteuert und unabhängig voneinander optimiert, um für jedes verbundene Gerät die bestmögliche Leistung zu erzielen.
Der BIG-IP Local Traffic Manager macht es überflüssig, dass Clients und Server für die Kommunikation den kleinsten gemeinsamen Nenner aushandeln müssen. Er vermittelt im Namen des Clients (dies wird als Stack Brokering bezeichnet) und optimiert mithilfe von TCP Express die clientseitige Übertragung, während er innerhalb des Netzwerks für den Server optimierte Verbindungen aufrechterhält, wie in der folgenden Abbildung dargestellt.

Häufig verfügen Unternehmen nicht über die nötigen Ressourcen, um ihre Altsysteme und -anwendungen zu entfernen oder zu ersetzen – oder dies ist gar nicht erforderlich. Zur Einbindung dieser Systeme vermittelt der BIG-IP Local Traffic Manager zwischen nicht optimierten oder sogar inkompatiblen Geräten, darunter:
- Beibehaltung separater MSS-Werte für Clients und Server, um sicherzustellen, dass beide Daten mit optimaler Geschwindigkeit übertragen. Clients und Server teilen einander die MSS mit, um die maximale Datenmenge zu bestimmen, die in einem Segment einer TCP-Kommunikation übertragen werden kann. Beide Seiten handeln die MSS aus, um eine möglichst kompatible Kommunikation zu ermöglichen. Dies führt jedoch häufig dazu, dass entweder der Client oder der Server nicht optimal arbeitet, da beide gezwungen sind, sich auf den kleinsten gemeinsamen MSS-Wert zu einigen.
- Optimierungen wie TCP Selective Acknowledgements (SACK) oder TCP-Zeitstempel (und vieles mehr) für Clients beibehalten, wenn diese eine Verbindung zu nicht unterstützten Servern herstellen.
- Dynamische und automatische Optimierung der TCP-Fenstergrößen und TCP-Überlastungsinformationen für jedes verbundene Gerät (jeden Client und jeden Server).
- Aufrechterhaltung der Interoperabilität zwischen Stacks wie Windows und älteren Solaris-Systemen, die nicht mit TCP-FIN-PUSHs kompatibel sind. Dies ist nur ein Beispiel für die verschiedenen Interoperabilitätsprobleme zwischen Stacks, mit denen Unternehmen häufig konfrontiert sind, wenn sie eine breite Nutzerbasis bedienen möchten.
Neben der Verbesserung der WAN-Kommunikation überträgt der BIG-IP Local Traffic Manager diese Funktionen auf die gesamte Infrastruktur, indem er als Brücke oder Übersetzungsinstanz zwischen allen Clients und Backend-Servern fungiert. Im Ergebnis verbessert der BIG-IP Local Traffic Manager die Leistung und kaschiert gleichzeitig Ineffizienzen im Netzwerk. Dadurch werden Kosten und Komplexität reduziert, da nicht mehr jeder Client und jeder Server aktualisiert und optimiert werden muss.
F5-Verbesserungen an TCP/IP-RFCs
Zu den wichtigsten TCP/IP-Verbesserungen von F5 gehören:
- Client-Beschleunigung und Fehlervermeidung
- Verbesserungen der Verbindungsauslastung
- Anpassbare TCP-Steuerung
Diese Verbesserungen wurden an branchenüblichen RFCs vorgenommen. In den folgenden Abschnitten werden einige der wichtigsten RFCs in TCP Express vorgestellt.
RFCs zur Clientbeschleunigung und Fehlervermeidung
- Verzögerte Bestätigungen, Nagle-Algorithmus (RFC 896, 1122) Ermöglicht dem BIG-IP Local Traffic Manager, die Datenübertragung zu beschleunigen, indem die Anzahl der zu übertragenden Pakete reduziert wird. Verzögerte Bestätigungen bieten einen standardisierten Mechanismus, um zu bestimmen, wann Bestätigungspakete gesendet werden müssen, und tragen so dazu bei, redundante Bestätigungspakete zu reduzieren. Darüber hinaus bietet der Nagle-Algorithmus ein standardisiertes Verfahren, um viele kleinere Pakete zu wenigen größeren Paketen zusammenzufassen.
- Selektive Bestätigungen (RFC 2018, RFC 2883) Ermöglicht BIG-IP Local Traffic Manager, verlorene und in falscher Reihenfolge eingetroffene Pakete in WANs und verlustbehafteten Netzwerken effektiver und schneller zu verarbeiten. Diese Funktion ist unter Windows XP und höher für die Internetkommunikation sowie in allen anderen modernen TCP-Stacks standardmäßig aktiviert. Erweiterungen ermöglichen es, die Verwendung einer SACK-Option anzugeben oder doppelte Pakete zu bestätigen.
- Explizite Überlastungsbenachrichtigung ECN (RFC 3168, 2481) ermöglicht es dem BIG-IP Local Traffic Manager, Gegenstellen proaktiv zu signalisieren, dass zwischengeschaltete Router überlastet sind, sodass sie die Übertragungsrate reduzieren und Paketverluste vermeiden können. Die reservierten Flags im TCP-Header (ECE und CWR) können verwendet werden, um der Gegenstelle eine Überlastung mitzuteilen.
- Begrenzte und schnelle Neuübertragungen (RFC 3042, RFC 2582) Ermöglicht die effiziente Neuübertragung verlorener Daten, wodurch die Auswirkungen von Zeitüberschreitungen infolge von Paketverlusten vermieden werden können.
- Adaptive anfängliche Überlastungsfenster (RFC 3390) Reduziert die Nachteile der Überlastungsvermeidung durch den TCP-Langsamstart. Studien mit größeren anfänglichen Überlastungsfenstern haben bei HTTP-Übertragungen über Satellitenverbindungen eine Leistungssteigerung von 30 % und bei Benutzern von 28,8-bps-Einwahlverbindungen eine Verbesserung von 10 % gezeigt, ohne dass die Verlustrate dadurch gestiegen ist. Bei TCP-Verbindungen, die sich einen Pfad teilen (16-KB-Übertragungen zu 100 Internet-Hosts), führte eine Vergrößerung des Fensters bei Übertragungen mit einem anfänglichen Fenster von vier Segmenten (MSS von 512 Byte) zu einer Verbesserung von etwa 25 % gegenüber einem anfänglichen Fenster von einem Segment.
RFCs zur Verbesserung der Verbindungsauslastung
- TCP Slow Start mit Überlastungsvermeidung (RFC 3390, 2581) Mit dieser Methode wird die richtige Datenmenge für die Übertragung über die Verbindung ermittelt, ohne diese zu überlasten und dadurch Paketverluste zu verursachen. Diese Funktion hilft Unternehmen, ihre Bandbreite besser auszulasten und höhere Durchsatzraten über ihre bestehenden öffentlichen Internetverbindungen und Standleitungen zu erzielen.
- Bandbreitenverzögerungssteuerung (RFC 793, RFC 2914, RFC 1257) F5 hat die Berechnung der Bandbreitenverzögerung verbessert und erweitert, um die optimale Netzwerklast genauer zu ermitteln, ohne die Netzwerkkapazität zu überschreiten.
RFCs für TCP-Erweiterungen
- Zeitstempel (RFC 1323) Der BIG-IP Local Traffic Manager ermöglicht die selektive Verwendung von Zeitstempeln, die dem TCP-Segment Daten hinzufügen und so weitere Optimierungen unterstützen. Obwohl Zeitstempel in modernen Netzwerken große Vorteile bieten, setzen einige ältere Router und NAT-Geräte die Zeitstempel auf null oder aktualisieren sie nicht, wodurch dieser Nutzen entfällt. Daher können diese und andere Funktionen für jedes Profil individuell konfiguriert werden.
- Risiken durch das vorzeitige Beenden des TCP-TIME-WAIT-Zustands reduzieren (RFC 1337) Durch die Optimierung des TIME-WAIT-Verhaltens lassen sich einige mögliche Kommunikationsfehler vermeiden. Insbesondere sollte beim Empfang von Reset-Segmenten im TIME-WAIT-Zustand keine Aktion ausgeführt werden.
- Schutz vor Angriffen auf Sequenznummern (RFC1948) TCP Express wehrt mithilfe einer sicheren ISN-Generierung die meisten Angriffe ab, bei denen Sequenznummern erraten werden.
- Verbesserung des TCP-Überlastungsmanagements (RFC 3168) TCP Express implementiert alle derzeit im Internet verfügbaren aktuellen Verfahren zur Vermeidung von TCP-Überlastungen und zur Wiederherstellung nach Überlastungen, um die nutzbare Bandbreite zu erhöhen und die Wiederherstellung im Falle einer Überlastung zu beschleunigen.
- Verbesserung des TCP-Slow-Starts für TCP mit großen Überlastungsfenstern (RFC 3742) Verwendet ein konservativeres Slow-Start-Verhalten, um große Datenverluste zu vermeiden, wenn Verbindungen sehr große TCP-Fenster verwenden.
- Geeignete Byte-Zählung (RFC 3465) Verwendet die Anzahl der zuvor unbestätigten Bytes, die jedes ACK bestätigt, um die Fenstergröße intelligenter zu skalieren und die TCP-Leistung zu steigern.
- Verbesserung des TCP-Algorithmus zur schnellen Wiederherstellung (NewReno) (RFC 3782) Die NewReno-Anpassung des TCP-Algorithmus zur schnellen Wiederherstellung sieht eine geringfügige Änderung vor, durch die ein TCP-Sender anhand partieller Bestätigungen Rückschlüsse darauf ziehen kann, welches Segment als Nächstes gesendet werden soll, wenn SACK hilfreich wäre, aber nicht verfügbar ist.
Gemeinsame Leistungsverbesserung
Da TCP Express buchstäblich Hunderte von Verbesserungen für die TCP-Interoperabilität unter realen Bedingungen implementiert und Fehler in kommerziell erhältlichen Produkt-Stacks (Windows 7 und höher, IBM AIX, Sun Solaris und weitere) behebt oder umgeht, ist keine einzelne Optimierungstechnik für den Großteil der Leistungssteigerungen verantwortlich. Diese Optimierungen hängen vom jeweiligen Client-/Servertyp und den Datenverkehrseigenschaften ab. Zum Beispiel:
- Bei Breitbandverbindungen mit deutlich höherer Bandbreite nutzt TCP die gesamte Verbindungskapazität naturgemäß weniger effizient, weshalb BIG-IP zusätzliche Optimierungen bietet.
- Bei einem Client mit Einwahlverbindung bestehen die wesentlichen Vorteile von TCP Express darin, dass BIG-IP die Gesamtzahl der bei einer bestimmten Transaktion übertragenen Pakete reduzieren und zudem schnellere Neuübertragungen ermöglichen kann.
BIG-IP reduziert weiterhin die Anzahl der Paketumlaufzeiten und beschleunigt Neuübertragungen wie bei Einwahlverbindungen, allerdings bei schnelleren Verbindungen. BIG-IP Local Traffic Manager und TCP Express optimieren außerdem die Überlastungssteuerung und die Fensterskalierung, um die maximale Bandbreite zu erhöhen. Obwohl die Verbesserungen für Benutzer von Einwahlverbindungen möglicherweise am deutlichsten spürbar sind, lassen sie sich bei Breitbandbenutzern statistisch am klarsten nachweisen, da einige Optimierungen die Spitzenleistung bei schnelleren Verbindungen erheblich steigern.
Generell gilt: Je mehr Daten ausgetauscht werden, desto stärker greifen Bandbreitenoptimierungen. Je weniger Daten ausgetauscht werden, desto stärker greifen Optimierungen der Paketumlaufzeit (Round-Trip Time, RTT). Daher profitieren Datenverkehrsprofile, bei denen nur wenige Daten ausgetauscht werden, wie etwa bei Einwahlverbindungen, stärker von Optimierungen als Breitbandverbindungen. Bei Datenverkehrsprofilen mit hohem Datenaustausch profitieren hingegen Breitbandverbindungen am stärksten von den Optimierungen. In beiden Fällen lassen sich mit TCP Express erhebliche Leistungssteigerungen erzielen.
Anpassbare TCP-Steuerelemente
Während TCP Express automatisch arbeitet und keine Änderungen erfordert, bietet BIG-IP Local Traffic Manager Benutzern eine erweiterte Kontrolle über den TCP-Stack, um die TCP-Kommunikation an spezifische Geschäftsanforderungen anzupassen. Dazu gehört die Möglichkeit, Optimierungen und Einstellungen auf der Ebene des virtuellen Servers für jede Anwendung auszuwählen, die über das Gerät bereitgestellt wird. Administratoren können mithilfe eines TCP-Profils die folgenden TCP-Variablen anpassen:
- TIME-WAIT-Recycling
- verzögerte ACKs
- Proxy-MSS
- Proxy-Optionen
- Verzögerte Annahme
- selektive Bestätigungen
- ECN
- Begrenzte Übertragung
- rfc1323
- langsamer Start
- Bandbreitenverzögerung
- Nagle
- Proxy-Puffer
Administratoren können diese Steuerelemente auch verwenden, um die TCP-Kommunikation an spezielle Netzwerkbedingungen oder Anwendungsanforderungen anzupassen. Kunden aus der Mobilfunk- und Dienstanbieterbranche können dank dieser Flexibilität ihre Leistung, Zuverlässigkeit und Bandbreitennutzung weiter optimieren, indem sie die Kommunikation auf bekannte Geräte (wie Mobiltelefone) und Netzwerkbedingungen abstimmen.
Anpassen der Stack-Einstellungen für Anwendungen
TCP Express bietet flexible Stack-Einstellungen zur Optimierung benutzerdefinierter Dienste. Sie können diese Einstellungen beispielsweise anpassen, um eine ASP-Anwendung zu optimieren, die mobilen Benutzern bereitgestellt wird. In der folgenden Tabelle werden die anpassbaren Stack-Einstellungen von BIG-IP Local Traffic Manager beschrieben.

Optimierung von hochinteraktivem Datenverkehr im LAN
Wenn der Datenverkehr in einem LAN stark interaktiv ist, empfiehlt F5 für eine optimale Leistung andere TCP-Einstellungen. F5 hat festgestellt, dass der Nagle-Algorithmus bei der Reduzierung der Paketanzahl sowie bei der allgemeinen Komprimierung und RAM-Zwischenspeicherung über ein WAN sehr gut funktioniert. Darüber hinaus können Anpassungen verschiedener Puffergrößen die stark interaktive Kommunikation in LANs mit geringer Latenz verbessern. Der einzige mögliche Nachteil ist dabei eine höhere Speicherauslastung auf dem BIG-IP Local Traffic Manager.
In der folgenden Tabelle werden die änderbaren Einstellungen des TCP-Profils beschrieben.

Weitere F5-Beschleunigungstechnologien
TCP Express wird durch weitere Beschleunigungsfunktionen und -produkte von F5 ergänzt, die die Downloadzeiten für Benutzer weiter verkürzen und die Infrastrukturressourcen optimieren.
Zu den weiteren Beschleunigungsfunktionen, die in den BIG-IP Local Traffic Manager integriert sind, gehören:
- Die HTTP-Komprimierung nutzt hochgradig konfigurierbare GZIP-Komprimierungsfunktionen, um die über eine Leitung übertragene Datenmenge zu reduzieren.
- Fast Cache entlastet Server und schont deren CPU, indem priorisierte Anwendungen zwischengespeichert werden und die Steuerungsmöglichkeiten für das Hosting mehrerer Anwendungen auf einem gemeinsam genutzten System erweitert werden. Die Zwischenspeicherung komprimierter Daten ermöglicht eine noch schnellere Bereitstellung von Inhalten und verbessert die Skalierbarkeit von BIG-IP.
- OneConnect erhöht die Serverkapazität um bis zu 60 %, indem TCP-Verbindungen von den Servern ausgelagert werden.
- Content Spooling reduziert den TCP-Overhead auf Servern und erhöht die Serverkapazität um bis zu 15 %, indem die Anzahl der auf den Servern erforderlichen TCP-Segmentierungen verringert wird.
Fazit
Für Unternehmen, die die Kapazität und Leistung ihrer Infrastruktur verbessern möchten, bietet der BIG-IP Local Traffic Manager eine einzigartige Lösung, durch die jeder verbundene Client und Server transparent effizienter arbeitet. Das einzigartige TCP Express von F5 sorgt für unübertroffene Verbesserungen der Netzwerk- und Anwendungsleistung unter realen Bedingungen und bietet Unternehmen ein beispielloses Maß an Kontrolle, um die TCP-Kommunikation für geschäftskritische Anwendungen zu optimieren.
VERÖFFENTLICHT AM 27. OKTOBER 2017
